CentOS 7 – Installing pymssql with pip, libgnutls.so.26 error

When trying to install pymssql with pip you may get a requirements error for libgnutls.so.26

To fix this error I took the following steps:

For the below you may need the EPEL repo, install this with the below command

yum install epel-release

Install gcc

yum install gcc

Install python-devel

yum install python-devel

Download freetds-devel and freetds for CentOS 7 and store in /tmp/ (or somewhere else, but remember where you stored it for later)

http://rpm.pbone.net/index.php3/stat/4/idpl/31220521/dir/redhat_el_7/com/freetds-devel-0.95.19-1.el7.x86_64.rpm.html

http://rpm.pbone.net/index.php3/stat/4/idpl/31220520/dir/redhat_el_7/com/freetds-0.95.19-1.el7.x86_64.rpm.html

Install both of them

yum install /tmp/freetds-0.95.19-1.el7.x86_64.rpm
yum install /tmp/freetds-devel-0.95.19-1.el7.x86_64.rpm

Run pip install pymssql again, it should hopefully succeed this time.